Notices
 

Thread: Black & Blue - and orange and red - and Yellow

Page 1 of 4 123 ... LastLast
Results 1 to 10 of 38
  1. Black & Blue - and orange and red - and Yellow 
    #1
    Platinum Member Burbler's Avatar
    Join Date
    Mar 2014
    Location
    Brizzle
    Posts
    1,494
    I only have one vice…I lie.
     
     

  2.  
    #2
    Platinum Member Burbler's Avatar
    Join Date
    Mar 2014
    Location
    Brizzle
    Posts
    1,494
    I only have one vice…I lie.
     
     

  3.  
    #3
    Platinum Member Burbler's Avatar
    Join Date
    Mar 2014
    Location
    Brizzle
    Posts
    1,494
    I only have one vice…I lie.
     
     

  4.  
    #4
    Platinum Member Burbler's Avatar
    Join Date
    Mar 2014
    Location
    Brizzle
    Posts
    1,494
    I only have one vice…I lie.
     
     

  5.  
    #5
    Platinum Member Burbler's Avatar
    Join Date
    Mar 2014
    Location
    Brizzle
    Posts
    1,494
    I only have one vice…I lie.
     
     

  6.  
    #6
    Platinum Member Burbler's Avatar
    Join Date
    Mar 2014
    Location
    Brizzle
    Posts
    1,494
    I only have one vice…I lie.
     
     

  7.  
    #7
    Senior Member
    Join Date
    Mar 2016
    Location
    Upavon
    Posts
    659
    Gutting, looking sad and broken.


    ignore bob it's totally fixable.
     
     

  8.  
    #8
    Senior Member
    Join Date
    Mar 2016
    Location
    Upavon
    Posts
    659
    In all seriousness to my (very) untrained eye it don't look too bad, handlebars frame and exhaust all look straight, and engine bits are just bolt on. The worst seems to be the fairing. I hate to say it but is it Street fighter time?
     
     

  9.  
    #9
    Platinum Member Burbler's Avatar
    Join Date
    Mar 2014
    Location
    Brizzle
    Posts
    1,494
    Quote Originally Posted by Badgerroy View Post
    I hate to say it but is it Street fighter time?

    I only have one vice…I lie.
     
     

  10.  
    #10
    Platinum Member Burbler's Avatar
    Join Date
    Mar 2014
    Location
    Brizzle
    Posts
    1,494
    Still not sure what caused it. Wheeled around OK and started first time. So plan is...

    Replace water-pump cover and refill. Sort out footrest and gear lever. See if everything works (brakes, suspension mainly).

    Go from there.
    I only have one vice…I lie.
     
     

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •