Notices
 

Thread: High pitched whirring sound from engine

Results 1 to 8 of 8
  1. High pitched whirring sound from engine 
    #1
    Active Member Dan's Avatar
    Join Date
    Jun 2014
    Posts
    92
    http://vid1353.photobucket.com/album...psv9sdymnc.mp4

    Got a whirring sound coming from my engine (zx9r B4)

    Got a few ideas of what it could be but I've no idea where to start with actual diagnosing. Anyone got any ideas as to what it could be?
     
     

  2.  
    #2
    Platinum Member
    Join Date
    Mar 2010
    Location
    Hiding in your blindspot
    Posts
    1,643
    Does it go away when you pull the clutch lever in and rev?
     
     

  3.  
    #3
    Active Member Dan's Avatar
    Join Date
    Jun 2014
    Posts
    92
    No - it's there all the time
     
     

  4.  
    #4
    Platinum Member
    Join Date
    Mar 2010
    Location
    Hiding in your blindspot
    Posts
    1,643
    Ok it's probably not the transmission/clutch then, how about the stator/Gene, i'd whip off the cover and have a look in there for any signs. Make sure you order up a new gasket or have the ability to make one, before you do. Also if you haven't already http://www.zx-9r.net/phpBB2/index.php i used to have a C2, and that place a mine of info and experience.
    Last edited by Mitch9128; 04-04-16 at 04:59 PM.
     
     

  5.  
    #5
    Senior Member
    Join Date
    Aug 2012
    Location
    bromham and melksham
    Posts
    571
    water pump bearing?
     
     

  6.  
    #6
    Active Member Dan's Avatar
    Join Date
    Jun 2014
    Posts
    92
    Still haven't got to the bottom of this. Had the alternator off and couldn't see anything obvious but I'm not 100% sure what I'm looking for.

    Had all the fairing off and put a metal rod to the engine in various places to try and pin down the noise, still no closer!
     
     

  7.  
    #7
    Senior Member
    Join Date
    Aug 2012
    Location
    bromham and melksham
    Posts
    571
    as always, without hearing ourselves its difficult for any of us to diagnose.
    firstly I will say I have known Z motors be noisy, its mainly from the clutch area. seemed to be a design problem. try to hear with the fller cap off if its louder, oil may get thrown out.
    secondly, as a tip. without a stethoscope, get a long screw driver and put the blade on different NON MOVING parts of the engine, put the handle against your ear. it helps pick up noises from different parts of the engine.

    just re read post, did you put metal rod to your ear? screwdrivers are softer!!

    still thinking waterpump impeller bearing or alternator.
    Last edited by wheelers; 20-05-16 at 07:30 PM.
     
     

  8.  
    #8
    Active Member Dan's Avatar
    Join Date
    Jun 2014
    Posts
    92
    Hi mate,

    It is noisy, particularly as the alternator chain needs tightening, but this noise came on suddenly whilst riding. I know the various noises the bike makes and this definitely isn't one of them!

    Good idea with the filler cap - hadn't thought of that one.

    Yeah - screwdriver didn't occur to me. The ratchet extension I had nearby worked well enough I tried that trick on the water pump cover as you suggested (and the alternator) and couldn't hear anything out of the ordinary.

    Cheers!
     
     

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •